Is got 10.4 vulnerable?
npm · 1 release from 10.4.0 to 10.4.0 · latest got is 16.2.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. got 10.4.0, the last 10.4 release, is affected by 1 known security advisory (1 medium), including CVE-2022-33987. Upgrade to 11.8.5 or later to fix all of them.
Upgrade with:
npm install got@11.8.5Advisories affecting got 10.4.0
Got allows a redirect to a UNIX socket
- Affected
- >=12.0.0 <12.1.0 · <11.8.5
- Fixed in
- 11.8.5, 12.1.0
Which of your client projects are still on got 10.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact got version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other got versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.