Is graphql 16.3 vulnerable?
npm · 1 release from 16.3.0 to 16.3.0 · latest graphql is 17.0.2 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. graphql 16.3.0, the last 16.3 release, is affected by 1 known security advisory (1 medium), including CVE-2023-26144. Upgrade to 16.8.1 or later to fix all of them.
Upgrade with:
npm install graphql@16.8.1Advisories affecting graphql 16.3.0
graphql Uncontrolled Resource Consumption vulnerability
- Affected
- >=16.3.0 <16.8.1
- Fixed in
- 16.8.1
Which of your client projects are still on graphql 16.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact graphql version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other graphql versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.