Is hapi 16.1 vulnerable?
npm · 2 releases from 16.1.0 to 16.1.1 · latest hapi is 18.1.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. hapi 16.1.1, the last 16.1 release, is affected by 1 known security advisory (1 high). 1 more affects earlier 16.1.x releases. At least one has no fixed release yet.
Advisories affecting hapi 16.1.1
Denial of Service in hapi
- Affected
- >=0.0.0
- Fixed in
- No fix released
Fixed within 16.1.x, affecting earlier releases
Denial of Service via malformed accept-encoding header in hapi
- Affected
- >=15.0.0 <16.1.1
- Fixed in
- 16.1.1
Which of your client projects are still on hapi 16.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact hapi version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other hapi versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.