Is http-proxy 1.11 vulnerable?

npm · 4 releases from 1.11.0 to 1.11.3 · latest http-proxy is 1.18.1 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. http-proxy 1.11.3, the last 1.11 release, is affected by 1 known security advisory (1 high). Upgrade to 1.18.1 or later to fix all of them.

Upgrade with:npm install http-proxy@1.18.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting http-proxy 1.11.3

Which of your client projects are still on http-proxy 1.11?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact http-proxy version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other http-proxy versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.