Is http-proxy 1.3 vulnerable?
npm · 1 release from 1.3.0 to 1.3.0 · latest http-proxy is 1.18.1 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. http-proxy 1.3.0, the last 1.3 release, is affected by 1 known security advisory (1 high). Upgrade to 1.18.1 or later to fix all of them.
Upgrade with:
npm install http-proxy@1.18.1Advisories affecting http-proxy 1.3.0
Denial of Service in http-proxy
- Affected
- <1.18.1
- Fixed in
- 1.18.1
Which of your client projects are still on http-proxy 1.3?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact http-proxy version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other http-proxy versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.