Is ip 2.0 vulnerable?

npm · 2 releases from 2.0.0 to 2.0.1 · latest ip is 2.0.1 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. ip 2.0.1, the last 2.0 release, is affected by 1 known security advisory (1 high), including CVE-2024-29415. 1 more affects earlier 2.0.x releases. At least one has no fixed release yet.

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting ip 2.0.1

  • HighCVE-2024-29415GHSA-2p57-rm9w-gvfp2 Jun 2024

    ip SSRF improper categorization in isPublic

    Affected
    <=2.0.1
    Fixed in
    No fix released

Fixed within 2.0.x, affecting earlier releases

  • LowCVE-2023-42282GHSA-78xj-cgh5-2h228 Feb 2024

    NPM IP package incorrectly identifies some private IP addresses as public

    Affected
    >=2.0.0 <2.0.1 · <1.1.9
    Fixed in
    1.1.9, 2.0.1

Which of your client projects are still on ip 2.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact ip version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other ip versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.