Is jquery 2.1 vulnerable?
npm · 5 releases from 2.1.0 to 2.1.4 · latest jquery is 4.0.0 · checked 1 Nov 2026
Yes: 4 known advisories
Yes. jquery 2.1.4, the last 2.1 release, is affected by 4 known security advisories (4 medium), including CVE-2020-11023, CVE-2020-11022, CVE-2019-11358. Upgrade to 3.5.0 or later to fix all of them.
npm install jquery@3.5.0Advisories affecting jquery 2.1.4
Potential XSS vulnerability in jQuery
- Affected
- >=1.0.3 <3.5.0
- Fixed in
- 3.5.0
Potential XSS vulnerability in jQuery
- Affected
- >=1.12.0 <3.5.0
- Fixed in
- 3.5.0
XSS in jQuery as used in Drupal, Backdrop CMS, and other products
- Affected
- >=1.1.4 <3.4.0
- Fixed in
- 3.4.0
Cross-Site Scripting (XSS) in jquery
- Affected
- <1.12.2 · >=1.12.3 <3.0.0
- Fixed in
- 1.12.2, 3.0.0
Which of your client projects are still on jquery 2.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact jquery version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other jquery versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.