Is knex 0.20 vulnerable?

npm · 15 releases from 0.20.0 to 0.20.15 · latest knex is 3.3.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. knex 0.20.15, the last 0.20 release, is affected by 1 known security advisory (1 high), including CVE-2016-20018. Upgrade to 2.4.0 or later to fix all of them.

Upgrade with:npm install knex@2.4.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting knex 0.20.15

  • HighCVE-2016-20018GHSA-4jv9-3563-23j319 Dec 2022

    Knex.js has a limited SQL injection vulnerability

    Affected
    <2.4.0
    Fixed in
    2.4.0

Which of your client projects are still on knex 0.20?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact knex version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other knex versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.