Is knex 0.4 vulnerable?
npm · 14 releases from 0.4.0 to 0.4.13 · latest knex is 3.3.0 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. knex 0.4.13, the last 0.4 release, is affected by 2 known security advisories (1 critical, 1 high), including CVE-2019-10757, CVE-2016-20018. Upgrade to 2.4.0 or later to fix all of them.
Upgrade with:
npm install knex@2.4.0Advisories affecting knex 0.4.13
Knex.js has a limited SQL injection vulnerability
- Affected
- <2.4.0
- Fixed in
- 2.4.0
SQL Injection in knex
- Affected
- <0.19.5
- Fixed in
- 0.19.5
Which of your client projects are still on knex 0.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact knex version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other knex versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.