Is koa 0.12 vulnerable?

npm · 3 releases from 0.12.0 to 0.12.2 · latest koa is 3.2.1 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. koa 0.12.2, the last 0.12 release, is affected by 3 known security advisories (1 critical, 1 high, 1 medium), including CVE-2025-25200, CVE-2026-27959, CVE-2025-32379. Upgrade to 2.16.4 or later to fix all of them.

Upgrade with:npm install koa@2.16.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting koa 0.12.2

  • HighCVE-2026-27959GHSA-7gcc-r8m5-44qm26 Feb 2026

    Koa has Host Header Injection via ctx.hostname

    Affected
    >=3.0.0 <3.1.2 · <2.16.4
    Fixed in
    2.16.4, 3.1.2
  • MediumCVE-2025-32379GHSA-x2rg-q646-7m2v9 Apr 2025

    Koajs vulnerable to Cross-Site Scripting (XSS) at ctx.redirect() function

    Affected
    <2.16.1 · >=3.0.0-alpha.1 <3.0.0-alpha.5
    Fixed in
    2.16.1, 3.0.0-alpha.5
  • CriticalCVE-2025-25200GHSA-593f-38f6-jp5m12 Feb 2025

    Inefficient Regular Expression Complexity in koa

    Affected
    >=2.0.0 <2.15.4 · >=3.0.0-alpha.0 <3.0.0-alpha.3 · >=1.0.0 <1.7.1 · <0.21.2
    Fixed in
    0.21.2, 1.7.1, 2.15.4, 3.0.0-alpha.3

Which of your client projects are still on koa 0.12?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact koa version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other koa versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.