Is lodash 0.9 vulnerable?

npm · 3 releases from 0.9.0 to 0.9.2 · latest lodash is 4.18.1 · checked 1 Nov 2026

Yes: 5 known advisories

Yes. lodash 0.9.2, the last 0.9 release, is affected by 5 known security advisories (1 critical, 2 high, 2 medium), including CVE-2019-10744, CVE-2021-23337, CVE-2018-16487. Upgrade to 4.18.0 or later to fix all of them.

Upgrade with:npm install lodash@4.18.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting lodash 0.9.2

  • MediumCVE-2026-2950GHSA-f23m-r3pf-42rh1 Apr 2026

    lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`

    Affected
    <4.18.0
    Fixed in
    4.18.0
  • HighCVE-2021-23337GHSA-35jh-r3h4-6jhm6 May 2021

    Command Injection in lodash

    Affected
    <4.17.21
    Fixed in
    4.17.21
  • CriticalCVE-2019-10744GHSA-jf85-cpcp-j69510 Jul 2019

    Prototype Pollution in lodash

    Affected
    <4.17.12
    Fixed in
    4.17.12
  • HighCVE-2018-16487GHSA-4xc9-xhrj-v5747 Feb 2019

    Prototype Pollution in lodash

    Affected
    <4.17.11
    Fixed in
    4.17.11
  • MediumCVE-2018-3721GHSA-fvqr-27wr-82fm26 Jul 2018

    Prototype Pollution in lodash

    Affected
    <4.17.5
    Fixed in
    4.17.5

Which of your client projects are still on lodash 0.9?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact lodash version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other lodash versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.