Is lodash 3.0 vulnerable?
npm · 2 releases from 3.0.0 to 3.0.1 · latest lodash is 4.18.1 · checked 2 Nov 2026
Yes: 5 known advisories
Yes. lodash 3.0.1, the last 3.0 release, is affected by 5 known security advisories (1 critical, 2 high, 2 medium), including CVE-2019-10744, CVE-2021-23337, CVE-2018-16487. Upgrade to 4.18.0 or later to fix all of them.
npm install lodash@4.18.0Advisories affecting lodash 3.0.1
lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`
- Affected
- <4.18.0
- Fixed in
- 4.18.0
Command Injection in lodash
- Affected
- <4.17.21
- Fixed in
- 4.17.21
Prototype Pollution in lodash
- Affected
- <4.17.12
- Fixed in
- 4.17.12
Prototype Pollution in lodash
- Affected
- <4.17.11
- Fixed in
- 4.17.11
Prototype Pollution in lodash
- Affected
- <4.17.5
- Fixed in
- 4.17.5
Which of your client projects are still on lodash 3.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact lodash version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other lodash versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.