Is lodash 4.9 vulnerable?
npm · 1 release from 4.9.0 to 4.9.0 · latest lodash is 4.18.1 · checked 2 Nov 2026
Yes: 10 known advisories
Yes. lodash 4.9.0, the last 4.9 release, is affected by 10 known security advisories (1 critical, 4 high, 5 medium), including CVE-2019-10744, CVE-2026-4800, CVE-2021-23337. Upgrade to 4.18.0 or later to fix all of them.
npm install lodash@4.18.0Advisories affecting lodash 4.9.0
lodash vulnerable to Code Injection via `_.template` imports key names
- Affected
- >=4.0.0 <4.18.0
- Fixed in
- 4.18.0
lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`
- Affected
- <4.18.0
- Fixed in
- 4.18.0
Lodash has Prototype Pollution Vulnerability in `_.unset` and `_.omit` functions
- Affected
- >=4.0.0 <4.17.23
- Fixed in
- 4.17.23
Regular Expression Denial of Service (ReDoS) in lodash
- Affected
- >=4.0.0 <4.17.21
- Fixed in
- 4.17.21
Command Injection in lodash
- Affected
- <4.17.21
- Fixed in
- 4.17.21
Prototype Pollution in lodash
- Affected
- >=3.7.0 <4.17.19
- Fixed in
- 4.17.19
Regular Expression Denial of Service (ReDoS) in lodash
- Affected
- >=4.7.0 <4.17.11
- Fixed in
- 4.17.11
Prototype Pollution in lodash
- Affected
- <4.17.12
- Fixed in
- 4.17.12
Prototype Pollution in lodash
- Affected
- <4.17.11
- Fixed in
- 4.17.11
Prototype Pollution in lodash
- Affected
- <4.17.5
- Fixed in
- 4.17.5
Which of your client projects are still on lodash 4.9?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact lodash version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other lodash versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.