Is marked 0.0 vulnerable?
npm · 9 releases from 0.0.1 to 0.0.9 · latest marked is 18.1.2 · checked 1 Nov 2026
Yes: 9 known advisories
Yes. marked 0.0.9, the last 0.0 release, is affected by 9 known security advisories (4 high, 5 medium), including CVE-2022-21681, CVE-2022-21680, CVE-2017-16114. Upgrade to 4.0.10 or later to fix all of them.
npm install marked@4.0.10Advisories affecting marked 0.0.9
Marked allows Regular Expression Denial of Service (ReDoS) attacks
- Affected
- <0.3.17
- Fixed in
- 0.3.17
Inefficient Regular Expression Complexity in marked
- Affected
- <4.0.10
- Fixed in
- 4.0.10
Inefficient Regular Expression Complexity in marked
- Affected
- <4.0.10
- Fixed in
- 4.0.10
Multiple Content Injection Vulnerabilities in marked
- Affected
- <0.3.1
- Fixed in
- 0.3.1
Sanitization bypass using HTML Entities in marked
- Affected
- <0.3.6
- Fixed in
- 0.3.6
Regular Expression Denial of Service in marked
- Affected
- <0.3.9
- Fixed in
- 0.3.9
Marked vulnerable to XSS from data URIs
- Affected
- <0.3.7
- Fixed in
- 0.3.7
Regular Expression Denial of Service in marked
- Affected
- <0.3.4
- Fixed in
- 0.3.4
VBScript Content Injection in marked
- Affected
- <0.3.3
- Fixed in
- 0.3.3
Which of your client projects are still on marked 0.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact marked version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other marked versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.