Is marked 0.6 vulnerable?

npm · 4 releases from 0.6.0 to 0.6.3 · latest marked is 18.1.2 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. marked 0.6.3, the last 0.6 release, is affected by 3 known security advisories (2 high, 1 low), including CVE-2022-21681, CVE-2022-21680. 1 more affects earlier 0.6.x releases. Upgrade to 4.0.10 or later to fix all of them.

Upgrade with:npm install marked@4.0.10

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting marked 0.6.3

  • HighCVE-2022-21681GHSA-5v2h-r2cx-5xgj14 Jan 2022

    Inefficient Regular Expression Complexity in marked

    Affected
    <4.0.10
    Fixed in
    4.0.10
  • HighCVE-2022-21680GHSA-rrrm-qjm4-v8hf14 Jan 2022

    Inefficient Regular Expression Complexity in marked

    Affected
    <4.0.10
    Fixed in
    4.0.10
  • LowGHSA-ch52-vgq2-943f3 Sept 2020

    Regular Expression Denial of Service in marked

    Affected
    >=0.4.0 <0.7.0
    Fixed in
    0.7.0

Fixed within 0.6.x, affecting earlier releases

  • MediumGHSA-xf5p-87ch-gxw25 Jun 2019

    Marked ReDoS due to email addresses being evaluated in quadratic time

    Affected
    >=0.3.14 <0.6.2
    Fixed in
    0.6.2

Which of your client projects are still on marked 0.6?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact marked version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other marked versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.