Is minimist 1.1 vulnerable?

npm · 4 releases from 1.1.0 to 1.1.3 · latest minimist is 1.2.8 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. minimist 1.1.3, the last 1.1 release, is affected by 2 known security advisories (1 critical, 1 medium), including CVE-2021-44906, CVE-2020-7598. Upgrade to 1.2.6 or later to fix all of them.

Upgrade with:npm install minimist@1.2.6

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting minimist 1.1.3

  • CriticalCVE-2021-44906GHSA-xvch-5gv4-984h18 Mar 2022

    Prototype Pollution in minimist

    Affected
    >=1.0.0 <1.2.6 · <0.2.4
    Fixed in
    0.2.4, 1.2.6
  • MediumCVE-2020-7598GHSA-vh95-rmgr-6w4m3 Apr 2020

    Prototype Pollution in minimist

    Affected
    <0.2.1 · >=1.0.0 <1.2.3
    Fixed in
    0.2.1, 1.2.3

Which of your client projects are still on minimist 1.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact minimist version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other minimist versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.