Is mongodb 5.6 vulnerable?

npm · 1 release from 5.6.0 to 5.6.0 · latest mongodb is 7.8.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. mongodb 5.6.0, the last 5.6 release, is affected by 1 known security advisory (1 medium), including CVE-2021-32050. Upgrade to 5.8.0 or later to fix all of them.

Upgrade with:npm install mongodb@5.8.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting mongodb 5.6.0

  • MediumCVE-2021-32050GHSA-vxvm-qww3-2fh729 Aug 2023

    MongoDB Driver may publish events containing authentication-related data

    Affected
    >=3.6.0 <3.6.10 · >=4.0.0 <4.17.0 · >=5.0.0 <5.8.0
    Fixed in
    3.6.10, 4.17.0, 5.8.0

Which of your client projects are still on mongodb 5.6?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact mongodb version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other mongodb versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.