Is mongoose 8.11 vulnerable?
npm · 1 release from 8.11.0 to 8.11.0 · latest mongoose is 9.11.4 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. mongoose 8.11.0, the last 8.11 release, is affected by 2 known security advisories (1 high, 1 medium), including CVE-2026-42334, CVE-2026-73562. Upgrade to 8.24.1 or later to fix all of them.
npm install mongoose@8.24.1Advisories affecting mongoose 8.11.0
Mongoose: Prototype pollution in mongoose update casting via __proto__-prefixed dotted path (Schema._getSchema/path getter)
- Affected
- <6.13.10 · >=7.0.0 <7.8.10 · >=8.0.0 <8.24.1 · >=9.0.0 <9.7.2
- Fixed in
- 6.13.10, 7.8.10, 8.24.1, 9.7.2
Mongoose's Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection
- Affected
- <6.13.9 · >=7.0.0 <7.8.9 · >=8.0.0 <8.22.1 · >=9.0.0 <9.1.6
- Fixed in
- 6.13.9, 7.8.9, 8.22.1, 9.1.6
Which of your client projects are still on mongoose 8.11?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact mongoose version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other mongoose versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.