Is mongoose 9.2 vulnerable?
npm · 5 releases from 9.2.0 to 9.2.4 · latest mongoose is 9.11.4 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. mongoose 9.2.4, the last 9.2 release, is affected by 1 known security advisory (1 medium), including CVE-2026-73562. Upgrade to 9.7.2 or later to fix all of them.
Upgrade with:
npm install mongoose@9.7.2Advisories affecting mongoose 9.2.4
Mongoose: Prototype pollution in mongoose update casting via __proto__-prefixed dotted path (Schema._getSchema/path getter)
- Affected
- <6.13.10 · >=7.0.0 <7.8.10 · >=8.0.0 <8.24.1 · >=9.0.0 <9.7.2
- Fixed in
- 6.13.10, 7.8.10, 8.24.1, 9.7.2
Which of your client projects are still on mongoose 9.2?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact mongoose version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other mongoose versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.