Is next 16.4 vulnerable?
npm · 4 releases from 16.4.0 to 16.4.3 · latest next is 16.4.3 · checked 1 Nov 2026
No known advisories in the last release
next 16.4.3, the last 16.4 release, has no known advisories. 3 advisories affect earlier 16.4.x releases, so update to 16.4.3.
npm install next@16.4.3Fixed within 16.4.x, affecting earlier releases
Next.js: Unauthenticated Remote Code Execution in `use cache` functions returning typed arrays
- Affected
- >=16.0.0 <16.4.1
- Fixed in
- 16.4.1
Next.js: Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used
- Affected
- >=10.0.0 <15.5.28 · >=16.0.0 <16.4.1
- Fixed in
- 15.5.28, 16.4.1
Next.js: Denial of Service in App Router using Server Actions
- Affected
- >=13.0.0 <15.5.28 · >=16.0.0 <16.4.1
- Fixed in
- 15.5.28, 16.4.1
Which of your client projects are still on next 16.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact next version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other next versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.