Is node-fetch 3.1 vulnerable?
npm · 2 releases from 3.1.0 to 3.1.1 · latest node-fetch is 3.3.2 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. node-fetch 3.1.1, the last 3.1 release, is affected by 1 known security advisory (1 medium), including CVE-2022-2596. 1 more affects earlier 3.1.x releases. Upgrade to 3.2.10 or later to fix all of them.
npm install node-fetch@3.2.10Advisories affecting node-fetch 3.1.1
node-fetch Inefficient Regular Expression Complexity
- Affected
- >=3.0.0 <3.2.10
- Fixed in
- 3.2.10
Fixed within 3.1.x, affecting earlier releases
node-fetch forwards secure headers to untrusted sites
- Affected
- >=3.0.0 <3.1.1 · <2.6.7
- Fixed in
- 2.6.7, 3.1.1
Which of your client projects are still on node-fetch 3.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact node-fetch version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other node-fetch versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.