Is nunjucks 1.0 vulnerable?
npm · 8 releases from 1.0.0 to 1.0.7 · latest nunjucks is 3.2.4 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. nunjucks 1.0.7, the last 1.0 release, is affected by 2 known security advisories (2 medium), including CVE-2023-2142, CVE-2016-10547. Upgrade to 3.2.4 or later to fix all of them.
Upgrade with:
npm install nunjucks@3.2.4Advisories affecting nunjucks 1.0.7
Nunjucks autoescape bypass leads to cross site scripting
- Affected
- <3.2.4
- Fixed in
- 3.2.4
Cross-Site Scripting in nunjucks
- Affected
- <2.4.3
- Fixed in
- 2.4.3
Which of your client projects are still on nunjucks 1.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact nunjucks version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other nunjucks versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.