Is path-to-regexp 1.4 vulnerable?
npm · 1 release from 1.4.0 to 1.4.0 · latest path-to-regexp is 9.0.0 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. path-to-regexp 1.4.0, the last 1.4 release, is affected by 1 known security advisory (1 high), including CVE-2024-45296. Upgrade to 1.9.0 or later to fix all of them.
Upgrade with:
npm install path-to-regexp@1.9.0Advisories affecting path-to-regexp 1.4.0
path-to-regexp outputs backtracking regular expressions
- Affected
- >=0.2.0 <1.9.0 · <0.1.10 · >=7.0.0 <8.0.0 · >=2.0.0 <3.3.0 · >=4.0.0 <6.3.0
- Fixed in
- 0.1.10, 1.9.0, 3.3.0, 6.3.0, 8.0.0
Which of your client projects are still on path-to-regexp 1.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact path-to-regexp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other path-to-regexp versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.