Is path-to-regexp 3.0 vulnerable?

npm · 1 release from 3.0.0 to 3.0.0 · latest path-to-regexp is 9.0.0 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. path-to-regexp 3.0.0, the last 3.0 release, is affected by 1 known security advisory (1 high), including CVE-2024-45296. Upgrade to 3.3.0 or later to fix all of them.

Upgrade with:npm install path-to-regexp@3.3.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting path-to-regexp 3.0.0

  • HighCVE-2024-45296GHSA-9wv6-86v2-598j9 Sept 2024

    path-to-regexp outputs backtracking regular expressions

    Affected
    >=0.2.0 <1.9.0 · <0.1.10 · >=7.0.0 <8.0.0 · >=2.0.0 <3.3.0 · >=4.0.0 <6.3.0
    Fixed in
    0.1.10, 1.9.0, 3.3.0, 6.3.0, 8.0.0

Which of your client projects are still on path-to-regexp 3.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact path-to-regexp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other path-to-regexp versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.