Is pdfjs-dist 1.10 vulnerable?
npm · 11 releases from 1.10.80 to 1.10.100 · latest pdfjs-dist is 6.5.438 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. pdfjs-dist 1.10.100, the last 1.10 release, is affected by 1 known security advisory (1 high), including CVE-2024-4367. 1 more affects earlier 1.10.x releases. Upgrade to 4.2.67 or later to fix all of them.
npm install pdfjs-dist@4.2.67Advisories affecting pdfjs-dist 1.10.100
PDF.js vulnerable to arbitrary JavaScript execution upon opening a malicious PDF
- Affected
- <4.2.67
- Fixed in
- 4.2.67
Fixed within 1.10.x, affecting earlier releases
Malicious PDF can inject JavaScript into PDF Viewer
- Affected
- >=2.0.0 <2.0.550 · <1.10.100
- Fixed in
- 1.10.100, 2.0.550
Which of your client projects are still on pdfjs-dist 1.10?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact pdfjs-dist version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other pdfjs-dist versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.