Is pdfjs-dist 3.8 vulnerable?

npm · 1 release from 3.8.162 to 3.8.162 · latest pdfjs-dist is 6.5.438 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. pdfjs-dist 3.8.162, the last 3.8 release, is affected by 1 known security advisory (1 high), including CVE-2024-4367. Upgrade to 4.2.67 or later to fix all of them.

Upgrade with:npm install pdfjs-dist@4.2.67

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting pdfjs-dist 3.8.162

  • HighCVE-2024-4367GHSA-wgrm-67xf-hhpq7 May 2024

    PDF.js vulnerable to arbitrary JavaScript execution upon opening a malicious PDF

    Affected
    <4.2.67
    Fixed in
    4.2.67

Which of your client projects are still on pdfjs-dist 3.8?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact pdfjs-dist version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other pdfjs-dist versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.