Is pdfjs-dist 5.6 vulnerable?
npm · 1 release from 5.6.205 to 5.6.205 · latest pdfjs-dist is 6.5.438 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. pdfjs-dist 5.6.205, the last 5.6 release, is affected by 1 known security advisory (1 high), including CVE-2026-16633. Upgrade to 6.2.108 or later to fix all of them.
Upgrade with:
npm install pdfjs-dist@6.2.108Advisories affecting pdfjs-dist 5.6.205
PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF
- Affected
- >=5.6.83 <6.2.108
- Fixed in
- 6.2.108
Which of your client projects are still on pdfjs-dist 5.6?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact pdfjs-dist version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other pdfjs-dist versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.