Is playwright 1.47 vulnerable?

npm · 3 releases from 1.47.0 to 1.47.2 · latest playwright is 1.64.1 · checked 1 Nov 2026

Yes: 1 known advisory

Yes. playwright 1.47.2, the last 1.47 release, is affected by 1 known security advisory (1 high), including CVE-2025-59288. Upgrade to 1.55.1 or later to fix all of them.

Upgrade with:npm install playwright@1.55.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting playwright 1.47.2

  • HighCVE-2025-59288GHSA-7mvr-c777-76hp14 Oct 2025

    Playwright downloads and installs browsers without verifying the authenticity of the SSL certificate

    Affected
    <1.55.1
    Fixed in
    1.55.1

Which of your client projects are still on playwright 1.47?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact playwright version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other playwright versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.