Is playwright 1.55 vulnerable?

npm · 2 releases from 1.55.0 to 1.55.1 · latest playwright is 1.64.1 · checked 1 Nov 2026

No known advisories in the last release

playwright 1.55.1, the last 1.55 release, has no known advisories. 1 advisory affects earlier 1.55.x releases, so update to 1.55.1.

Update within 1.55:npm install playwright@1.55.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Fixed within 1.55.x, affecting earlier releases

  • HighCVE-2025-59288GHSA-7mvr-c777-76hp14 Oct 2025

    Playwright downloads and installs browsers without verifying the authenticity of the SSL certificate

    Affected
    <1.55.1
    Fixed in
    1.55.1

Which of your client projects are still on playwright 1.55?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact playwright version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other playwright versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.