Is postcss-selector-parser 6.1 vulnerable?
npm · 6 releases from 6.1.0 to 6.1.5 · latest postcss-selector-parser is 7.1.7 · checked 2 Nov 2026
No known advisories in the last release
postcss-selector-parser 6.1.5, the last 6.1 release, has no known advisories. 2 advisories affect earlier 6.1.x releases, so update to 6.1.5.
npm install postcss-selector-parser@6.1.5Fixed within 6.1.x, affecting earlier releases
PostCSS: Quadratic complexity in flat selector parsing allows CPU exhaustion
- Affected
- >=7.0.0 <7.1.6 · <6.1.5
- Fixed in
- 6.1.5, 7.1.6
postcss-selector-parser allows denial of service through uncontrolled AST recursion
- Affected
- >=6.1.0 <6.1.3 · >=7.1.0 <7.1.3
- Fixed in
- 6.1.3, 7.1.3
Which of your client projects are still on postcss-selector-parser 6.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact postcss-selector-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other postcss-selector-parser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.