Is postcss 8.5 vulnerable?
npm · 33 releases from 8.5.0 to 8.5.32 · latest postcss is 8.5.32 · checked 1 Nov 2026
No known advisories in the last release
postcss 8.5.32, the last 8.5 release, has no known advisories. 4 advisories affect earlier 8.5.x releases, so update to 8.5.32.
npm install postcss@8.5.32Fixed within 8.5.x, affecting earlier releases
PostCSS: incomplete fix of GHSA-6g55-p6wh-862q — attacker-controlled sourceMappingURL reads arbitrary .map files when `from` is unset
- Affected
- <8.5.23
- Fixed in
- 8.5.23
PostCSS: Path Traversal in Previous Source Map Auto-Loading (sourceMappingURL) leads to Arbitrary .map File Disclosure
- Affected
- <8.5.18
- Fixed in
- 8.5.18
PostCSS: Arbitrary file read and information disclosure via attacker-controlled sourceMappingURL in CSS comments
- Affected
- <8.5.12
- Fixed in
- 8.5.12
PostCSS has XSS via Unescaped </style> in its CSS Stringify Output
- Affected
- <8.5.10
- Fixed in
- 8.5.10
Which of your client projects are still on postcss 8.5?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact postcss version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other postcss versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.