Is pug 0.0 vulnerable?

npm · 1 release from 0.0.0 to 0.0.0 · latest pug is 3.0.4 · checked 2 Nov 2026

Yes: 2 known advisories

Yes. pug 0.0.0, the last 0.0 release, is affected by 2 known security advisories (2 medium), including CVE-2024-36361, CVE-2021-21353. Upgrade to 3.0.3 or later to fix all of them.

Upgrade with:npm install pug@3.0.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting pug 0.0.0

  • MediumCVE-2024-36361GHSA-3965-hpx2-q59724 May 2024

    Pug allows JavaScript code execution if an application accepts untrusted input

    Affected
    <3.0.3
    Fixed in
    3.0.3
  • MediumCVE-2021-21353GHSA-p493-635q-r6gr3 Mar 2021

    Remote code execution via the `pretty` option.

    Affected
    <3.0.1
    Fixed in
    3.0.1

Which of your client projects are still on pug 0.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact pug version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other pug versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.