Is puppeteer 1.0 vulnerable?

npm · 1 release from 1.0.0 to 1.0.0 · latest puppeteer is 25.16.0 · checked 4 Nov 2026

Yes: 1 known advisory

Yes. puppeteer 1.0.0, the last 1.0 release, is affected by 1 known security advisory (1 medium), including CVE-2019-5786. Upgrade to 1.13.0 or later to fix all of them.

Upgrade with:npm install puppeteer@1.13.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting puppeteer 1.0.0

  • MediumCVE-2019-5786GHSA-c2gp-86p4-59352 Sept 2020

    Use-After-Free in puppeteer

    Affected
    <1.13.0
    Fixed in
    1.13.0

Which of your client projects are still on puppeteer 1.0?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact puppeteer version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other puppeteer versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.