Is qs 6.15 vulnerable?

npm · 5 releases from 6.15.0 to 6.15.4 · latest qs is 6.17.1 · checked 1 Nov 2026

Yes: 3 known advisories

Yes. qs 6.15.4, the last 6.15 release, is affected by 3 known security advisories (3 medium), including CVE-2026-110816, CVE-2026-82562, CVE-2026-82417. 1 more affects earlier 6.15.x releases. Upgrade to 6.16.1 or later to fix all of them.

Upgrade with:npm install qs@6.16.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting qs 6.15.4

  • MediumCVE-2026-110816GHSA-6pq8-jhm2-2vcw27 Oct 2026

    qs : qs.stringify with arrayFormat 'comma' throws an uncaught TypeError on array elements carrying a non-callable own toString (DoS)

    Affected
    >=6.7.0 <6.16.1
    Fixed in
    6.16.1
  • MediumCVE-2026-82562GHSA-x5fp-wj9c-mxmx2 Sept 2026

    qs array-limit bypass via bracket-key comma parsing

    Affected
    >=6.14.2 <6.16.0
    Fixed in
    6.16.0
  • MediumCVE-2026-82417GHSA-4mjr-xmp4-gh2g2 Sept 2026

    qs: Denial of Service via Attacker Controlled isBuffer

    Affected
    >=2.2.5 <6.16.0
    Fixed in
    6.16.0

Fixed within 6.15.x, affecting earlier releases

  • MediumCVE-2026-8723GHSA-q8mj-m7cp-5q2622 May 2026

    qs has a remotely triggerable DoS: qs.stringify crashes with TypeError on null/undefined entries in comma-format arrays when encodeValuesOnly is set

    Affected
    >=6.11.1 <6.15.2
    Fixed in
    6.15.2

Which of your client projects are still on qs 6.15?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact qs version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other qs versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.