Is rollup 3.10 vulnerable?
npm · 2 releases from 3.10.0 to 3.10.1 · latest rollup is 4.67.4 · checked 2 Nov 2026
Yes: 2 known advisories
Yes. rollup 3.10.1, the last 3.10 release, is affected by 2 known security advisories (2 high), including CVE-2026-27606, CVE-2024-47068. Upgrade to 3.30.0 or later to fix all of them.
Upgrade with:
npm install rollup@3.30.0Advisories affecting rollup 3.10.1
Rollup 4 has Arbitrary File Write via Path Traversal
- Affected
- <2.80.0 · >=3.0.0 <3.30.0 · >=4.0.0 <4.59.0
- Fixed in
- 2.80.0, 3.30.0, 4.59.0
DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS
- Affected
- >=3.0.0 <3.29.5 · >=4.0.0 <4.22.4 · <2.79.2
- Fixed in
- 2.79.2, 3.29.5, 4.22.4
Which of your client projects are still on rollup 3.10?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact rollup version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other rollup versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.