Is semver 1.0 vulnerable?
npm · 15 releases from 1.0.0 to 1.0.14 · latest semver is 7.8.6 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. semver 1.0.14, the last 1.0 release, is affected by 1 known security advisory (1 high), including CVE-2015-8855. Upgrade to 4.3.2 or later to fix all of them.
Upgrade with:
npm install semver@4.3.2Advisories affecting semver 1.0.14
Regular Expression Denial of Service in semver
- Affected
- >=1.0.4 <4.3.2
- Fixed in
- 4.3.2
Which of your client projects are still on semver 1.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact semver version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other semver versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.