Is semver 5.1 vulnerable?

npm · 2 releases from 5.1.0 to 5.1.1 · latest semver is 7.8.5 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. semver 5.1.1, the last 5.1 release, is affected by 1 known security advisory (1 high), including CVE-2022-25883. Upgrade to 5.7.2 or later to fix all of them.

Upgrade with:npm install semver@5.7.2

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting semver 5.1.1

  • HighCVE-2022-25883GHSA-c2qf-rxjj-qqgw21 Jun 2023

    semver vulnerable to Regular Expression Denial of Service

    Affected
    >=7.0.0 <7.5.2 · >=6.0.0 <6.3.1 · >=2.0.0-alpha <5.7.2
    Fixed in
    5.7.2, 6.3.1, 7.5.2

Which of your client projects are still on semver 5.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact semver version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other semver versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.