Is send 0.4 vulnerable?
npm · 4 releases from 0.4.0 to 0.4.3 · latest send is 1.2.1 · checked 2 Nov 2026
Yes: 3 known advisories
Yes. send 0.4.3, the last 0.4 release, is affected by 3 known security advisories (1 medium, 2 low), including CVE-2015-8859, CVE-2024-43799, CVE-2014-6394. Upgrade to 0.19.0 or later to fix all of them.
Upgrade with:
npm install send@0.19.0Advisories affecting send 0.4.3
send vulnerable to template injection that can lead to XSS
- Affected
- <0.19.0
- Fixed in
- 0.19.0
Root Path Disclosure in send
- Affected
- <0.11.1
- Fixed in
- 0.11.1
Directory Traversal in send
- Affected
- <0.8.4
- Fixed in
- 0.8.4
Which of your client projects are still on send 0.4?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact send version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other send versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.