Is sequelize 5.19 vulnerable?
npm · 9 releases from 5.19.0 to 5.19.8 · latest sequelize is 6.37.8 · checked 1 Nov 2026
Yes: 5 known advisories
Yes. sequelize 5.19.8, the last 5.19 release, is affected by 5 known security advisories (4 critical, 1 medium), including CVE-2026-69240, CVE-2023-22578, CVE-2023-22579. Upgrade to 6.37.4 or later to fix all of them.
npm install sequelize@6.37.4Advisories affecting sequelize 5.19.8
Sequelize: SQL Injection (Oracle DB)
- Affected
- <6.37.4
- Fixed in
- 6.37.4
Sequelize - Default support for “raw attributes” when using parentheses
- Affected
- <6.29.0
- Fixed in
- 6.29.0
Unsafe fall-through in getWhereConditions
- Affected
- <6.28.1
- Fixed in
- 6.28.1
Sequelize vulnerable to SQL Injection via replacements
- Affected
- <6.19.1
- Fixed in
- 6.19.1
Sequelize information disclosure vulnerability
- Affected
- <6.28.1
- Fixed in
- 6.28.1
Which of your client projects are still on sequelize 5.19?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sequelize version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other sequelize versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.