Is serve-static 1.8 vulnerable?
npm · 2 releases from 1.8.0 to 1.8.1 · latest serve-static is 2.2.1 · checked 1 Nov 2026
Yes: 1 known advisory
Yes. serve-static 1.8.1, the last 1.8 release, is affected by 1 known security advisory (1 low), including CVE-2024-43800. Upgrade to 1.16.0 or later to fix all of them.
Upgrade with:
npm install serve-static@1.16.0Advisories affecting serve-static 1.8.1
serve-static vulnerable to template injection that can lead to XSS
- Affected
- <1.16.0 · >=2.0.0 <2.1.0
- Fixed in
- 1.16.0, 2.1.0
Which of your client projects are still on serve-static 1.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact serve-static version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other serve-static versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.