Is sharp 0.31 vulnerable?
npm · 4 releases from 0.31.0 to 0.31.3 · latest sharp is 0.35.5 · checked 1 Nov 2026
Yes: 4 known advisories
Yes. sharp 0.31.3, the last 0.31 release, is affected by 4 known security advisories (4 high), including CVE-2026-114111, CVE-2026-114112, CVE-2026-114113. Upgrade to 0.35.5 or later to fix all of them.
npm install sharp@0.35.5Advisories affecting sharp 0.31.3
sharp : Vulnerability in librsvg dependency CVE-2026-96889
- Affected
- <0.35.5
- Fixed in
- 0.35.5
sharp: Vulnerabilities in libheif: GHSA-g89c-p67h-r497 and GHSA-2jg2-4ch7-h545
- Affected
- <0.35.4
- Fixed in
- 0.35.4
sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591
- Affected
- <0.35.0
- Fixed in
- 0.35.0
sharp vulnerability in libwebp dependency CVE-2023-4863
- Affected
- <0.32.6
- Fixed in
- 0.32.6
Which of your client projects are still on sharp 0.31?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sharp version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other sharp versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.