Is socket.io-parser 4.0 vulnerable?
npm · 6 releases from 4.0.0 to 4.0.5 · latest socket.io-parser is 4.2.7 · checked 2 Nov 2026
Yes: 3 known advisories
Yes. socket.io-parser 4.0.5, the last 4.0 release, is affected by 3 known security advisories (2 high, 1 medium), including CVE-2026-69185, CVE-2026-33151, CVE-2023-32695. 1 more affects earlier 4.0.x releases. Upgrade to 4.2.7 or later to fix all of them.
npm install socket.io-parser@4.2.7Advisories affecting socket.io-parser 4.0.5
Socket.IO: Zero-attachment Memory Exhaustion
- Affected
- >=4.0.0 <4.2.7 · >=3.4.0 <3.4.5 · <3.3.6
- Fixed in
- 3.3.6, 3.4.5, 4.2.7
socket.io allows an unbounded number of binary attachments
- Affected
- <3.3.5 · >=3.4.0 <3.4.4 · >=4.0.0 <4.2.6
- Fixed in
- 3.3.5, 3.4.4, 4.2.6
Insufficient validation when decoding a Socket.IO packet
- Affected
- >=4.0.4 <4.2.3 · >=3.4.0 <3.4.3 · <3.3.4
- Fixed in
- 3.3.4, 3.4.3, 4.2.3
Fixed within 4.0.x, affecting earlier releases
Insufficient validation when decoding a Socket.IO packet
- Affected
- >=4.0.0 <4.0.5 · >=4.1.0 <4.2.1 · <3.3.3 · >=3.4.0 <3.4.2
- Fixed in
- 3.3.3, 3.4.2, 4.0.5, 4.2.1
Which of your client projects are still on socket.io-parser 4.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact socket.io-parser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other socket.io-parser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.