Is socket.io 4.1 vulnerable?
npm · 4 releases from 4.1.0 to 4.1.3 · latest socket.io is 4.8.4 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. socket.io 4.1.3, the last 4.1 release, is affected by 1 known security advisory (1 medium), including CVE-2024-38355. Upgrade to 4.6.2 or later to fix all of them.
Upgrade with:
npm install socket.io@4.6.2Advisories affecting socket.io 4.1.3
socket.io has an unhandled 'error' event
- Affected
- <2.5.1 · >=3.0.0 <4.6.2
- Fixed in
- 2.5.1, 4.6.2
Which of your client projects are still on socket.io 4.1?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact socket.io version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other socket.io versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.