Is sweetalert2 10.4 vulnerable?

npm · 1 release from 10.4.0 to 10.4.0 · latest sweetalert2 is 11.26.25 · checked 1 Nov 2026

Yes: 2 known advisories

Yes. sweetalert2 10.4.0, the last 10.4 release, is affected by 2 known security advisories (2 low). Upgrade to 11.22.4 or later to fix all of them.

Upgrade with:npm install sweetalert2@11.22.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting sweetalert2 10.4.0

  • LowGHSA-8jh9-wqpf-q52c23 Nov 2022

    sweetalert2 v8.19.1 and above contains hidden functionality

    Affected
    >=8.19.1 <11.22.4
    Fixed in
    11.22.4
  • LowGHSA-pg98-6v7f-2xfv23 Nov 2022

    sweetalert2 v9.17.4 and above contains hidden functionality

    Affected
    >=9.17.4 <11.22.4
    Fixed in
    11.22.4

Which of your client projects are still on sweetalert2 10.4?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sweetalert2 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other sweetalert2 versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.