Is sweetalert2 11.10 vulnerable?
npm · 9 releases from 11.10.0 to 11.10.8 · latest sweetalert2 is 11.26.25 · checked 2 Nov 2026
Yes: 5 known advisories
Yes. sweetalert2 11.10.8, the last 11.10 release, is affected by 5 known security advisories (5 low). Upgrade to 11.22.4 or later to fix all of them.
npm install sweetalert2@11.22.4Advisories affecting sweetalert2 11.10.8
sweetalert2 contains potentially undesirable behavior
- Affected
- >=11.6.14 <11.22.4
- Fixed in
- 11.22.4
sweetalert2 v8.19.1 and above contains hidden functionality
- Affected
- >=8.19.1 <11.22.4
- Fixed in
- 11.22.4
sweetalert2 v9.17.4 and above contains hidden functionality
- Affected
- >=9.17.4 <11.22.4
- Fixed in
- 11.22.4
sweetalert2 v10.16.10 and above contains hidden functionality
- Affected
- >=10.16.10 <11.22.4
- Fixed in
- 11.22.4
sweetalert2 v11.4.9 and above contains hidden functionality
- Affected
- >=11.4.9 <11.22.4
- Fixed in
- 11.22.4
Which of your client projects are still on sweetalert2 11.10?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sweetalert2 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other sweetalert2 versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.