Is sweetalert2 9.13 vulnerable?

npm · 5 releases from 9.13.0 to 9.13.4 · latest sweetalert2 is 11.26.25 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. sweetalert2 9.13.4, the last 9.13 release, is affected by 1 known security advisory (1 low). Upgrade to 11.22.4 or later to fix all of them.

Upgrade with:npm install sweetalert2@11.22.4

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting sweetalert2 9.13.4

  • LowGHSA-8jh9-wqpf-q52c23 Nov 2022

    sweetalert2 v8.19.1 and above contains hidden functionality

    Affected
    >=8.19.1 <11.22.4
    Fixed in
    11.22.4

Which of your client projects are still on sweetalert2 9.13?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact sweetalert2 version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other sweetalert2 versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.