Is terser 3.8 vulnerable?
npm · 3 releases from 3.8.0 to 3.8.2 · latest terser is 5.51.2 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. terser 3.8.2, the last 3.8 release, is affected by 1 known security advisory (1 high), including CVE-2022-25858. Upgrade to 4.8.1 or later to fix all of them.
Upgrade with:
npm install terser@4.8.1Advisories affecting terser 3.8.2
Terser insecure use of regular expressions leads to ReDoS
- Affected
- <4.8.1 · >=5.0.0 <5.14.2
- Fixed in
- 4.8.1, 5.14.2
Which of your client projects are still on terser 3.8?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact terser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other terser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.