Is terser 5.14 vulnerable?
npm · 3 releases from 5.14.0 to 5.14.2 · latest terser is 5.51.2 · checked 2 Nov 2026
No known advisories in the last release
terser 5.14.2, the last 5.14 release, has no known advisories. 1 advisory affects earlier 5.14.x releases, so update to 5.14.2.
Update within 5.14:
npm install terser@5.14.2Fixed within 5.14.x, affecting earlier releases
Terser insecure use of regular expressions leads to ReDoS
- Affected
- <4.8.1 · >=5.0.0 <5.14.2
- Fixed in
- 4.8.1, 5.14.2
Which of your client projects are still on terser 5.14?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact terser version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other terser versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.