Is three 0.116 vulnerable?

npm · 2 releases from 0.116.0 to 0.116.1 · latest three is 0.187.0 · checked 2 Nov 2026

Yes: 1 known advisory

Yes. three 0.116.1, the last 0.116 release, is affected by 1 known security advisory (1 high), including CVE-2020-28496. Upgrade to 0.125.0 or later to fix all of them.

Upgrade with:npm install three@0.125.0

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting three 0.116.1

  • HighCVE-2020-28496GHSA-fq6p-x6j3-cmmq1 Mar 2021

    Denial of service in three

    Affected
    <0.125.0
    Fixed in
    0.125.0

Which of your client projects are still on three 0.116?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact three version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other three versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.