Is trim-newlines 1.0 vulnerable?
npm · 1 release from 1.0.0 to 1.0.0 · latest trim-newlines is 5.0.0 · checked 2 Nov 2026
Yes: 1 known advisory
Yes. trim-newlines 1.0.0, the last 1.0 release, is affected by 1 known security advisory (1 high), including CVE-2021-33623. Upgrade to 3.0.1 or later to fix all of them.
Upgrade with:
npm install trim-newlines@3.0.1Advisories affecting trim-newlines 1.0.0
Uncontrolled Resource Consumption in trim-newlines
- Affected
- <3.0.1 · >=4.0.0 <4.0.1
- Fixed in
- 3.0.1, 4.0.1
Which of your client projects are still on trim-newlines 1.0?
NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact trim-newlines version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.
Other trim-newlines versions
Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the npm registry. Refreshed daily.